Enhanced eFax Portal Outage
Incident Report for CallHarbor
Resolved
Our engineers have continued to monitor the eFax platform and have continued to see it perform at typical levels. We are resolving this incident.
Posted Jan 17, 2023 - 16:59 EST
Monitoring
eFax services are back online. We will update shortly with information pertaining to the incident.
Posted Jan 17, 2023 - 09:58 EST
Investigating
We have identified that our enhanced eFax service is currently experiencing issues with loading the web portal. We are working on identifying the cause for the issue and hope to have an update very shortly. Our engineers are fully engaged working towards resolution.
Posted Jan 17, 2023 - 08:31 EST
This incident affected: Faxing (Enhanced eFax).