Scheduled for May 09, 2025 at 11:45 PM – May 10, 2025 at 1:54 AM
Affects
Detroit, MI - Point of Presence
Under maintenance from 11:45 PM to 1:54 AM
Call Recording
Under maintenance from 11:45 PM to 1:54 AM
Provisioning
Under maintenance from 11:45 PM to 1:54 AM
Inbound Calling
Under maintenance from 11:45 PM to 1:54 AM
Outbound Calling
Under maintenance from 11:45 PM to 1:54 AM
Phone Registration
Under maintenance from 11:45 PM to 1:54 AM
Updates
Completed
May 10, 2025 at 1:54 AM
Completed
May 10, 2025 at 1:54 AM
The scheduled maintenance has been completed.
In progress
May 09, 2025 at 11:45 PM
In progress
May 09, 2025 at 11:45 PM
Maintenance is now in progress
Planned
May 09, 2025 at 11:45 PM
Planned
May 09, 2025 at 11:45 PM
We will be performing scheduled maintenance on our DTW datacenter tonight between 7:45 PM and 8:45 PM EST.
This maintenance will affect our DTW location only. PHX and ATL locations will remain fully functional and are not impacted by this work.
During this window, there is a small possibility of intermittent call disruptions at the DTW location, including dropped calls. However, we expect any impact to be minimal and brief.
Please note that the CallHarbor network will remain fully operational throughout the maintenance window, and we are taking proactive measures to reduce any potential disruption.
Our team will be monitoring all systems closely and will provide updates if any unexpected issues arise.