CallHarbor - Upstream Carrier - Outbound Calling – Incident details

Upstream Carrier - Outbound Calling

Resolved
Degraded performance
Started 8 days agoLasted about 1 hour

Affected

Detroit, MI - Point of Presence

Operational from 3:08 PM to 4:21 PM

Outbound Calling

Operational from 3:08 PM to 4:21 PM

Atlanta, GA - Point of Presence

Operational from 3:08 PM to 4:21 PM

Outbound Calling

Operational from 3:08 PM to 4:21 PM

Phoenix, AZ - Point of Presence

Operational from 3:08 PM to 4:21 PM

Outbound Calling

Operational from 3:08 PM to 4:21 PM

Updates
  • Resolved
    Resolved

    This incident is now being marked as resolved as we are continuing to see outbound calls processing at normal rates.

  • Monitoring
    Monitoring

    Update: The upstream carriers have implemented a fix and we are monitoring the situation. We will consider this incident resolved after monitoring for some time.

  • Identified
    Identified

    We are currently experiencing increased outbound call failures due to outages affecting multiple upstream carriers on the public switched telephone network (PSTN).

    Our team is actively engaged with these carriers, and they are working to reroute traffic and implement a resolution.

    Please note that the CallHarbor network itself is operating normally, and the impact is isolated to these upstream connections. The majority of outbound calls are still processing successfully.

    We will continue to monitor the situation closely and provide updates as they become available.