CallHarbor - Faxing Service Degradation — Inbound & Outbound – Incident details

Faxing Service Degradation — Inbound & Outbound

Resolved
Major outage
Started 14 days agoLasted about 1 hour

Affected

eFax

Degraded performance from 7:44 PM to 9:02 PM

Inbound Fax

Degraded performance from 7:44 PM to 9:02 PM

Outbound Fax

Degraded performance from 7:44 PM to 9:02 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results closely. Faxing service should now be restored for affected customers. If you continue to experience issues, please reach out to our support team.

  • Identified
    Identified

    We are currently experiencing impaired performance with our faxing service affecting both inbound and outbound faxes. Some customers may experience failed transmissions, delays, or incomplete deliveries during this time.

    Our team has identified the issue and is actively working to restore full service. We apologize for any inconvenience and will provide updates as more information becomes available.