Scheduled for February 10, 2026 at 3:00 AM – 5:17 AM
Affects
Manager Portal
Under maintenance from 3:00 AM to 5:17 AM
Web Phone
Under maintenance from 3:00 AM to 5:17 AM
Analytics
Under maintenance from 3:00 AM to 5:17 AM
Messaging
Under maintenance from 3:00 AM to 5:17 AM
Web Interface
Under maintenance from 3:00 AM to 5:17 AM
Detroit, MI - Point of Presence
Under maintenance from 3:00 AM to 5:17 AM
Updates
Completed
February 10, 2026 at 5:17 AM
Completed
February 10, 2026 at 5:17 AM
Maintenance has completed successfully.
In progress
February 10, 2026 at 3:00 AM
In progress
February 10, 2026 at 3:00 AM
Maintenance is now in progress
Planned
February 10, 2026 at 3:00 AM
Planned
February 10, 2026 at 3:00 AM
A non-service-impacting platform upgrade will take place, this update is to enhance functionality across the platform.
This upgrade is not expected to disrupt service. In the unlikely event of a service impact that is not resolved promptly, please contact our main line at 1 (833) 363-VOIP and follow the prompts for assistance.
Upgrade Process: The upgrade will be executed in stages across our multiple geographic locations, ensuring that phones will seamlessly failover between these locations during the upgrade.
Important Note: If your phones are not configured for failover (manually configured or unsupported devices), you may experience limited functionality or partial outages. Rest assured, all CallHarbor direct/retail endpoints are configured for failover to ensure uninterrupted service.