CallHarbor - eFax Deliverability – Incident details

eFax Deliverability

Resolved
Partial outage
Started 8 months agoLasted 1 day

Affected

Updates
  • Resolved
    Resolved

    We are continuing to see faxes flow through successfully. This issue is considered resolved. If you are still experiencing any issues with eFax please reach out to our support team. support@callharbor.com or by dialing 611 from your desk phone.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Investigating
    Update

    Multiple engineers are engaged and continuously working on this deliverability issue. We expect updates very shortly.

  • Investigating
    Investigating

    We are currently investigating an issue with increased eFax deliverability errors. You may be unable to send or receive eFax files during this time. We have our engineers engaged looking into this issue and will provide updates as we receive them.