CallHarbor - eFax - Fax Bridge Outage – Incident details

eFax - Fax Bridge Outage

Resolved
Partial outage
Started 3 months agoLasted about 1 hour

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are seeing fax bridges come back online, we are continuing to monitor the situation and will provide further updates as we receive them from upstream providers.

  • Identified
    Identified

    We are currently experiencing an outage on physical fax bridges due to an upstream provider. We are working with the upstream provider to resolve this as fast as possible. All eFax services outside of physical fax bridges are still fully functional. We will provide updates as we receive them. If you do not have access to your eFax portal, or need assistance do not hesitate to reach out to support@callharbor.com or give us a call at 833-363-VOIP for further assistance.