eFax Deliverability
Incident Report for CallHarbor
Resolved
We are continuing to see faxes flow through successfully. This issue is considered resolved. If you are still experiencing any issues with eFax please reach out to our support team. support@callharbor.com or by dialing 611 from your desk phone.
Posted Dec 04, 2023 - 11:42 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2023 - 11:31 EST
Update
Multiple engineers are engaged and continuously working on this deliverability issue. We expect updates very shortly.
Posted Dec 04, 2023 - 10:52 EST
Investigating
We are currently investigating an issue with increased eFax deliverability errors. You may be unable to send or receive eFax files during this time. We have our engineers engaged looking into this issue and will provide updates as we receive them.
Posted Dec 03, 2023 - 10:52 EST
This incident affected: Faxing (Enhanced eFax).