CallHarbor - High Wind: Partial Outage – Incident details

High Wind: Partial Outage

Resolved
Degraded performance
Started over 7 years agoLasted about 1 hour

Affected

Updates
  • Resolved
    Resolved

    Our technicians have restored service to our wireless dedicated circuit customers. Please contact 313.278.4522 if you are still experiencing an outage.

  • Investigating
    Investigating

    We are currently experiencing an outage with some of our voice dedicated circuits. All phones should automatically failover to your primary connection, if you are without phone service please call 313.278.4522 to speak to a representative for further assistance. We have technicians working on the issue currently.