CallHarbor - Network Outage - Phoenix, AZ - 08/22/2026 – Incident details

Network Outage - Phoenix, AZ - 08/22/2026

Resolved
Major outage
Started 13 days agoLasted about 1 hour

Affected

Phoenix, AZ - Point of Presence

Major outage from 1:30 AM to 2:34 AM

Inbound Calling

Major outage from 1:30 AM to 2:34 AM

Outbound Calling

Major outage from 1:30 AM to 2:34 AM

Phone Registration

Major outage from 1:30 AM to 2:34 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    Please be advised that our Phoenix, AZ data center is currently experiencing a network outage. All devices that were registered to our Phoenix, AZ data center have automatically migrated to our other two data centers. We want to assure you that all CallHarbor services are operational and stable. No impact to CallHarbor services is expected at this time. We are collaborating closely with the data center team as they work to restore full connectivity.