CallHarbor - RingGenius Outage – Incident details

RingGenius Outage

Resolved
Operational
Started 9 days agoLasted about 2 hours

Affected

RingGenius Platform

Major outage from 4:02 PM to 6:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    CallHarbor clients and clients who have been migrated from RingGenius to CallHarbor's platform are NOT impacted by this outage.

    RingGenius' platform is currently experiencing an outage due to an upstream carrier. RingGenius is aware of the outage and is working as fast as possible to get services back online. We will provide updates as we receive them from RingGenius / the upstream carrier.