CallHarbor - Enhanced eFax Portal Outage – Incident details

Enhanced eFax Portal Outage

Resolved
Major outage
Started over 1 year agoLasted about 8 hours

Affected

Updates
  • Resolved
    Resolved

    Our engineers have continued to monitor the eFax platform and have continued to see it perform at typical levels. We are resolving this incident.

  • Monitoring
    Monitoring

    eFax services are back online. We will update shortly with information pertaining to the incident.

  • Investigating
    Investigating

    We have identified that our enhanced eFax service is currently experiencing issues with loading the web portal. We are working on identifying the cause for the issue and hope to have an update very shortly. Our engineers are fully engaged working towards resolution.