CallHarbor - Platform Portal - Call Recording Display – Incident details

Platform Portal - Call Recording Display

Resolved
Operational
Started 4 months agoLasted about 7 hours

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating an issue impacting the display of recorded calls from within the portal. Call recordings do appear to be continuing as normal, however they are failing to show within the call history portion of the page. Our engineers are fully engaged and working on resolving this issue as soon as possible. We will provide updates here as we receive them.