CallHarbor - eFax Fax Bridge / Physical Fax Deliverability – Incident details

eFax Fax Bridge / Physical Fax Deliverability

Resolved
Operational
Started 4 months agoLasted about 21 hours

Affected

eFax

Partial outage from 8:29 PM to 5:32 PM

Inbound Fax

Partial outage from 8:29 PM to 5:32 PM

Outbound Fax

Partial outage from 8:29 PM to 5:32 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. The upstream vendor has restored all services.

  • Investigating
    Investigating

    Our physical fax service is currently experiencing an outage for some users due to an issue with our upstream provider. We are actively working with them to restore service as quickly as possible.

    • Impact: Physical fax transmissions are unavailable for some users.

    • Workaround: All other eFax services (excluding physical fax bridges) are operational. You may utilize our eFax portal to send and receive faxes until this issue is resolved.

    We will provide updates as they become available.

    For assistance, please contact support@callharbor.com or call 833-363-VOIP.